آفلاین
user-avatar

آپدیت نشدن کامپوزر به دلیل ورژن php

9 ماه پیش
توسط سید حسین رضوی آپدیت شد
آفلاین
user-avatar
سید حسین رضوی ( 80426 تجربه )
2 سال پیش
تخصص : برنامه نویس وب و طراح رابط کاربری

سلام من یه پروژه لاراول 5.6 رو دانلود کردم موقع دستور کامپوزر آپدیت گفت php سیستم شما 7.0.1 هست و نیاز به 7.1.3 دارم من اومدم php توی ومپ رو به 7.2.9 تغییر دادم ولی باز هم هرچی دستور کامپوزر آپدیت میزنم میگه هنوز ورژن 7.0.1 رو داری من php ومپ هم به 7.2.9 تغییر دادم
الان باید چیکار کنم؟؟؟؟

بهترین پاسخ انتخاب شده توسط سید حسین رضوی
آفلاین
user-avatar
سید حسین رضوی
2 سال پیش

توی ترمینال میزنم نسخه پی اچ پی چنده میزد 7.0.1 رفتم توی بخش اینوایرومنت ها آدرس رو انجا تغییر دادم به نسخه بالاتر درست شد

آفلاین
user-avatar
حسام موسوی ( 406046 تجربه )
2 سال پیش
تخصص : طراح و برنامه نویس

در ترمینال دستور php -v رو بزنید و ببینید چه ورژنی رو نشون میده

آفلاین
user-avatar
علی بیات ( 388368 تجربه )
2 سال پیش
تخصص : توسعه دهنده ارشد وب

composer رو دوباره نصب کن٬ در طول نصب میپرسه از چه نسخه php میخواهید استفاده کنید.

آفلاین
user-avatar
سید حسین رضوی ( 80426 تجربه )
2 سال پیش
تخصص : برنامه نویس وب و طراح رابط کاربری

توی ترمینال میزنم نسخه پی اچ پی چنده میزد 7.0.1 رفتم توی بخش اینوایرومنت ها آدرس رو انجا تغییر دادم به نسخه بالاتر درست شد

آفلاین
user-avatar
masoud ( 190 تجربه )
1 سال پیش

سلام. چطور میتونم نسخه پی اچ پی رو از طریق کامپوزر به 7 ارتقا بدم؟

@hesammousavi

آفلاین
user-avatar
حسام موسوی ( 406046 تجربه )
1 سال پیش
تخصص : طراح و برنامه نویس

@masoud2525
php مگه پکیجه که با composer بیاین به ورژن 7 ارتقاع بدید ؟
اگر در سرور cpanel دارید از طریق cpanel تغییر میدید
اگر روی سیستم خودتون هست و از xampp دارید استفاده میکنید ورژن جدیدتر xampp رو دریافت و نصب کنید

آفلاین
user-avatar
Javad Ansari ( 50 تجربه )
9 ماه پیش

من همین مشکل رو دارم .
دقیقا composer update گیر میکنه سر connect شدن
نفهمیدم ایشون چطوری درست کرد ؟
*رفتم توی بخش اینوایرومنت ها آدرس رو انجا تغییر دادم به نسخه بالاتر درست شد

آفلاین
user-avatar
سید حسین رضوی ( 80426 تجربه )
9 ماه پیش
تخصص : برنامه نویس وب و طراح رابط کاربری

با سلام ببینید من مشکلم سر این بود که ومپ نسخه php رو به 7.3 تغییر داده بودم درست بود اما وقتی توی ترمینال دستور php -v میزدم نسخه پایین تر نشون میداد که این اتفاق به خاطر کامپوزر میوفته یا کاری که من انجام دادم انجام بدید که پیشنهاد نمیشه بهترین کار اینه که کامپوزر رو مجدد نصب کنید و هنگام نصب نسخه php مورد نظر رو انتخاب کنید

برای ارسال پاسخ باید وارد سایت شوید