استفاده schedule run در هاست اشتراکی

- 3 هفته پیش
توسط Alimotreb آپدیت شد
سعید محمدیان ( 10120 تجربه )
3 هفته پیش

با سلام من از هاست اشتراکی cpanel استفاده میکنم یه کرون جاب ساختم ادرس دهی کردم
usr/local/bin/php /home/clikshop/public_html/artisan schedule:run
و کدها در kernel تعریف کرده ام وقتی توی سیستم خودم اجراش می‌کنم به درستی کار می‌کنه ولی روی هاست اشتراکی کار نمکنه نمیدونم مشکل از کجاست دوستان خواهشا کمک کنید

حسام موسوی ( 207394 تجربه )
3 هفته پیش
تخصص : طراح و برنامه نویس

سلام در اکثر هاست‌های اشتراکی دسترسی به php مشکل داره و دسترسی‌ها بسته است
شما فایل log رو ببینید ایا اروری بر نمیگردونه
و اینکه اگر شما درست اپلود کرده باشید پروژه رو artisan باید قبل از public_html باشه نه قبلش

mahdi khanzadi ( 50377 تجربه )
3 هفته پیش
تخصص : برنامه نویس سمت سرور

برای ران کردن کرون جاب روی هاست اشتراکی دستوراتی که باعث ران کردن artisan میشه رو توی فایل php بنویسید بعدش اون فایل رو ران کنید.

https://laravel.com/docs/5.8/artisan#programmatically-executing-commands

به صورت زیر میشه:

Artisan::call('schedule:run');
Alimotreb ( 167492 تجربه )
3 هفته پیش
تخصص : کانفیگ سرور و برنامه نویس

سلام
@saeedbzines

کد خطا رو بزارید تا دقیق تر بررسی شه

سعید محمدیان ( 10120 تجربه )
3 هفته پیش

خطایی که برام میاد
Parse error: syntax error, unexpected T_CLASS, expecting T_STRING or T_VARIABLE or '$' in /home/daadappi/public_html/artisan on line 33
ورژن استفاده در لاراول ۷.۲ ولی ورژن که از این طریق زدم همچین پیامی اومد
PHP 5.3.29 (cli) (built: Jul 4 2018 16:12:52)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2014 Zend Technologies
with the ionCube PHP Loader v10.3.7, Copyright (c) 2002-2019, by ionCube Ltd.
with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies
with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH

حسام موسوی ( 207394 تجربه )
3 هفته پیش
تخصص : طراح و برنامه نویس

اون چیزی که مشخصه ورژن php 5.3 هست و شما باید ورژن php در سرور رو به 7.2 ارتقاع بدید

علی بیات ( 193487 تجربه )
3 هفته پیش
تخصص : توسعه دهنده ارشد وب

درود
نسخه PHP رو ارتقا بدید و فایل‌های پروژه لاراولی رو یه فولدر عقب‌تر از public_html قرار بدید که به موارد امنیتی برخورد نکنید

Alimotreb ( 167492 تجربه )
3 هفته پیش
تخصص : کانفیگ سرور و برنامه نویس

سلام
@saeedbzines

روی ورژن های 7 PHP باید ران کنید !

برای ارسال پاسخ باید وارد سایت شوید