آفلاین
user-avatar

نصب نشدن passport در لاراول

2 سال پیش
توسط مهدی آپدیت شد
آفلاین
user-avatar
ترنج صوفی ( 3480 تجربه )
2 سال پیش

سلام ، من میخوام پکیج passport رو نصب و استفاده کنم ولی با ارور های زیر رو به رو میشم ، باید چیکار کنم ؟

    C:UsersLenovoDesktoplaravel>composer require laravel/passport

    Using version ^6.0 for laravel/passport
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

      Problem 1
        - don't install league/oauth2-server 7.0.0|remove league/oauth2-server 5.1.6
        - don't install league/oauth2-server 7.0.0|don't install league/oauth2-server 5.1.6
        - don't install league/oauth2-server 7.0.0|don't install league/oauth2-server 5.1.6
        - laravel/passport v6.0.0 requires league/oauth2-server ^7.0 -> satisfiable by league/oauth2-server[7.0.0].
        - Installation request for laravel/passport ^6.0 -> satisfiable by laravel/passport[v6.0.0].
        - Installation request for league/oauth2-server (locked at 5.1.6) -> satisfiable by league/oauth2-server[5.1.6].
بهترین پاسخ انتخاب شده توسط ترنج صوفی
آفلاین
user-avatar
مهدی
2 سال پیش

composer.lock و پوشه vendor رو حذف کن

آفلاین
user-avatar
حسام موسوی ( 382469 تجربه )
2 سال پیش
تخصص : طراح و برنامه نویس

مثل اینکه نیاز به پکیج league/oauth2-server داره پکیج league/oauth2-server رو نصب کنید با استفاده از composer ببینید چی میشه

آفلاین
user-avatar
ترنج صوفی ( 3480 تجربه )
2 سال پیش

به ارور زیر میخورم تو نصبش :

>composer require league/oauth2-server

Using version ^7.0 for league/oauth2-server
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - laravel/passport v1.0.0 requires league/oauth2-server ~5.0 -> satisfiable by league/oauth2-server[5.0.0, 5.0.0-RC1, 5.0.0-RC2, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.1.1, 5.1.2, 5.1.3, 5.1.4, 5.1.5, 5.1.6, 5.1.x-dev] but these conflict with your requirements or minimum-stability.
    - laravel/passport v1.0.0 requires league/oauth2-server ~5.0 -> satisfiable by league/oauth2-server[5.0.0, 5.0.0-RC1, 5.0.0-RC2, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.1.1, 5.1.2, 5.1.3, 5.1.4, 5.1.5, 5.1.6, 5.1.x-dev] but these conflict with your requirements or minimum-stability.
    - laravel/passport v1.0.0 requires league/oauth2-server ~5.0 -> satisfiable by league/oauth2-server[5.0.0, 5.0.0-RC1, 5.0.0-RC2, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.1.1, 5.1.2, 5.1.3, 5.1.4, 5.1.5, 5.1.6, 5.1.x-dev] but these conflict with your requirements or minimum-stability.
    - Installation request for laravel/passport (locked at v1.0.0, required as 1.0.*) -> satisfiable by laravel/passport[v1.0.0].

Installation failed, reverting ./composer.json to its original content.
آفلاین
user-avatar
حسام موسوی ( 382469 تجربه )
2 سال پیش
تخصص : طراح و برنامه نویس

لطف کنید محتوای composer.json رو قرار بدید

آفلاین
user-avatar
ترنج صوفی ( 3480 تجربه )
2 سال پیش
{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "php": ">=7.0.0",
        "codeitnowin/barcode": "^2.1",
        "cviebrock/eloquent-sluggable": "^4.4",
        "fideloper/proxy": "~3.3",
        "guzzlehttp/guzzle": "^6.3",
        "intervention/image": "^2.4",
        "laravel/framework": "5.5.*",
        "laravel/passport": "1.0.*",
        "laravel/socialite": "^3.0",
        "laravel/tinker": "~1.0",
        "morilog/jalali": "^2.3",
        "uxweb/sweet-alert": "^1.4"
    },
    "require-dev": {
        "filp/whoops": "~2.0",
        "fzaninotto/faker": "~1.4",
        "mockery/mockery": "~1.0",
        "phpunit/phpunit": "~6.0",
        "symfony/thanks": "^1.0"
    },
    "autoload": {
        "classmap": [
            "database/seeds",
            "database/factories"
        ],
        "psr-4": {
            "App\\": "app/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "Tests\\": "tests/"
        }
    },
    "extra": {
        "laravel": {
            "dont-discover": [
            ]
        }
    },
    "scripts": {
        "post-root-package-install": [
            "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
        ],
        "post-create-project-cmd": [
            "@php artisan key:generate"
        ],
        "post-autoload-dump": [
            "Illuminate\\Foundation\\ComposerScripts::postAutoloadDump",
            "@php artisan package:discover"
        ]
    },
    "config": {
        "preferred-install": "dist",
        "sort-packages": true,
        "optimize-autoloader": true
    }
}
آفلاین
user-avatar
مهدی ( 23202 تجربه )
2 سال پیش

یادمه قبلا میخواستم نصب کنم آخرش به این نتیجه رسیدم که یا باید لاراول رو به 5.6 ارتقا داد یا نسخه 4 رو واسه لاراول 5.5 نصب کرد

composer require laravel/passport=~4.0

link

آفلاین
user-avatar
ترنج صوفی ( 3480 تجربه )
2 سال پیش

C:\Users\Lenovo\Desktop\laravel>composer require laravel/passport=~4.0
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install laravel/passport v4.0.3
    - Conclusion: don't install laravel/passport v4.0.2
    - Conclusion: don't install laravel/passport v4.0.1
    - Conclusion: remove league/oauth2-server 5.1.6
    - Installation request for laravel/passport ~4.0 -> satisfiable by laravel/passport[v4.0.0, v4.0.1, v4.0.2, v4.0.3].
    - Conclusion: don't install league/oauth2-server 5.1.6
    - laravel/passport v4.0.0 requires league/oauth2-server ^6.0 -> satisfiable by league/oauth2-server[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1].
    - don't install league/oauth2-server 6.0.0|don't install league/oauth2-server 5.1.6
    - don't install league/oauth2-server 6.0.1|don't install league/oauth2-server 5.1.6
    - don't install league/oauth2-server 6.0.2|don't install league/oauth2-server 5.1.6
    - don't install league/oauth2-server 6.1.0|don't install league/oauth2-server 5.1.6
    - don't install league/oauth2-server 6.1.1|don't install league/oauth2-server 5.1.6
    - Installation request for league/oauth2-server (locked at 5.1.6) -> satisfiable by league/oauth2-server[5.1.6].

Installation failed, reverting ./composer.json to its original content.
آفلاین
user-avatar
مهدی ( 23202 تجربه )
2 سال پیش

composer.lock و پوشه vendor رو حذف کن

برای ارسال پاسخ باید وارد سایت شوید