نصب پکیج sitemap

- 7 ماه پیش
توسط رضاکیامنش آپدیت شد
رضاکیامنش ( 275 تجربه )
9 ماه پیش

سلام وقت بخیر دوستان ،من قبلا پکیج laravelium/sitemap رو نصب کرده بودم ولی الان مدتیه انگار روی gitlab رفته و موقع نصب با کامپوزر ارور میده (با پراکسی حل میشه) ولی در مرحله بعد هنگام نصب یوزر و پسورد میخواد و نمیتونم نصب کنم!!!
کسی میتونه راهنمایی کنه؟؟که باید چه مراحلی رو طی کنم

علی بیات ( 126647 تجربه )
9 ماه پیش
تخصص : توسعه دهنده ارشد وب

چه نسخه‌ای از لاراول رو استفاده می‌کنید؟
نسخه‌های این پکیج باید با نسخه لاراولی که استفاده میکنید همخوانی داشته باشه..

برای لاراول نسخه ۵.۷ :

"laravelium/sitemap": "3.0.*"

برای لاراول نسخه ۵.۶ :

"laravelium/sitemap": "2.8.*"

برای لاراول نسخه ۵.۵ :

"laravelium/sitemap": "2.7.*"
رضاکیامنش ( 275 تجربه )
9 ماه پیش

سلام وعرض ادب دوست عزیز،از هر دو نسخه 5.6 و 5.7 استفاده میکنم ولی متناسب با ورژن لاراول میزنم...
میشه خودتونم تست کنید،فک کنم جدیدا اینجور شده

علی بیات ( 126647 تجربه )
9 ماه پیش
تخصص : توسعه دهنده ارشد وب

@rezakiyamanesh
من نسخه ۳.۰.۱ این پکیج رو روی لاراول ۵.۷.۱۲ نصب کردم. مشکلی نداره

رضاکیامنش ( 275 تجربه )
9 ماه پیش

@ali.bayatمیشه بگید کی نصب کردید؟یا اینکه از طریق gitlab بوده؟
ایا ربطی به گیت داره نصب این پکیج؟

علی بیات ( 126647 تجربه )
9 ماه پیش
تخصص : توسعه دهنده ارشد وب

@rezakiyamanesh
حدود ۴۰ دقیقه پیش.. البته با وی‌پی‌ان

developer ( 28541 تجربه )
9 ماه پیش
تخصص : برنامه نویس

منم دیروز نصبش کردم درست بود البته با tor وصل بود
اول ارور داد ولی بعد وصل کردم درست شد

رضاکیامنش ( 275 تجربه )
9 ماه پیش

ممنون بابت پاسخ هاتون،فقط اگه میشه اسم تور یا... که استفاده میکنید رو بگید که دانلود کنم

developer ( 28541 تجربه )
9 ماه پیش
تخصص : برنامه نویس

tor یک پروکسی هست که البته توی ابونتو کار میکنه نمیدونم ویندوز هم داره یا نه

mahdi3516 ( 70 تجربه )
7 ماه پیش

سلام من میخام پکیج sitemap را نصب کنم ورژن لاراول هم 5.5 هست اما ارور میده؟؟؟؟؟
C:\wamp64\www\janebi>composer require laravelium/sitemap
Using version ^3.0 for laravelium/sitemap
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for laravelium/sitemap ^3.0 -> satisfiable by laravelium/sitemap[v3.0.1].
  • Conclusion: remove laravel/framework v5.5.44
  • Conclusion: don't install laravel/framework v5.5.44
  • laravelium/sitemap v3.0.1 requires illuminate/support 5.7.* -> satisfiable by illuminate/support[v5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.15, v5.7.2, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7, v5.7.8
    , v5.7.9].
  • illuminate/support v5.7.0 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.1 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.10 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.11 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.15 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.2 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.3 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.4 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.5 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.6 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.7 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.8 conflicts with laravel/framework[v5.5.44].
  • illuminate/support v5.7.9 conflicts with laravel/framework[v5.5.44].
  • Installation request for laravel/framework (locked at v5.5.44, required as 5.5.*) -> satisfiable by laravel/framework[v5.5.44].

Installation failed, reverting ./composer.json to its original content.

C:\wamp64\www\janebi>composer require laravelium/sitemap
Using version ^3.0 for laravelium/sitemap
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for laravelium/sitemap ^3.0 -> satisfiable by laravelium/sitemap[v3.0.1].
  • laravelium/sitemap v3.0.1 requires illuminate/support 5.7.* -> satisfiable by illuminate/support[5.7.x-dev, v5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.15, v5.7.2, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.
    7.7, v5.7.8, v5.7.9] but these conflict with your requirements or minimum-stability.

Installation failed, reverting ./composer.json to its original content.

C:\wamp64\www\janebi>composer require laravelium/sitemap
Using version ^3.0 for laravelium/sitemap
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • The requested package laravel/framework (locked at v5.5.44, required as 5.7.*) is satisfiable by laravel/framework[v5.5.44] but these conflict with your requirements or minimum-stability.
    Problem 2
  • cviebrock/eloquent-sluggable 4.3.0 requires illuminate/support ~5.5.0 -> satisfiable by illuminate/support[5.5.x-dev, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.3
    6, v5.5.37, v5.5.39, v5.5.40, v5.5.41, v5.5.43, v5.5.44] but these conflict with your requirements or minimum-stability.
  • cviebrock/eloquent-sluggable 4.3.0 requires illuminate/support ~5.5.0 -> satisfiable by illuminate/support[5.5.x-dev, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.3
    6, v5.5.37, v5.5.39, v5.5.40, v5.5.41, v5.5.43, v5.5.44] but these conflict with your requirements or minimum-stability.
  • cviebrock/eloquent-sluggable 4.3.0 requires illuminate/support ~5.5.0 -> satisfiable by illuminate/support[5.5.x-dev, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.3
    6, v5.5.37, v5.5.39, v5.5.40, v5.5.41, v5.5.43, v5.5.44] but these conflict with your requirements or minimum-stability.
  • Installation request for cviebrock/eloquent-sluggable 4.3 -> satisfiable by cviebrock/eloquent-sluggable[4.3.0].

Installation failed, reverting ./composer.json to its original content.

رضاکیامنش ( 275 تجربه )
7 ماه پیش

سلام @mahdi3516 از این استفاده کن :
composer require roumen/sitemap

برای ارسال پاسخ باید وارد سایت شوید