map.ir

2 هفته پیش
توسط hosein آپدیت شد
hosein ( 1400 تجربه )
2 هفته پیش

سلام من توی پروژه از این کتابخانه استفاده کردم اما توی gradle همش خطا زیر میده ممنون میشم راهنمایی کنید :

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve com.android.support:support-vector-drawable:28.0.0.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve com.android.support:appcompat-v7:28.0.0.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.vectordrawable:vectordrawable:{strictly 1.0.0}.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.appcompat:appcompat:{strictly 1.0.0}.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.core:core:{strictly 1.0.0}.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.appcompat:appcompat:1.0.2.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.appcompat:appcompat:1.0.0.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.core:core:1.0.1.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.vectordrawable:vectordrawable:1.0.1.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.core:core:1.0.0.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

ERROR: Unable to resolve dependency for ':@react-native-mapbox-gl_maps@debug/compileClasspath': Could not resolve androidx.vectordrawable:vectordrawable:1.0.0.
Show Details
Affected Modules: @react-native-mapbox-gl_maps

اینم فایلهای build :

 buildscript {
    ext {
        buildToolsVersion = "28.0.3"
        minSdkVersion = 16
        compileSdkVersion = 28
        targetSdkVersion = 28
    }
    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath('com.android.tools.build:gradle:3.4.0')

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}
الیاس بشکنی ( 53385 تجربه )
2 هفته پیش
تخصص : برنامه نویس موبایل

از یه ف ی ل ت ر شکن استفاده کنید
یا از shecan.ir

hosein ( 1400 تجربه )
2 هفته پیش

@elyasbeshkani

استفاده کردم جواب نداد

برای ارسال پاسخ باید وارد سایت شوید