علت لود نشدن fontawesome در phpstorm

- 7 روز پیش
توسط سید زاهد حسینی آپدیت شد
سید زاهد حسینی ( 710 تجربه )
1 هفته پیش

سلام دوستان من وقتی روی یک پروژه کار میکردم و سیستم ثبت مقالات رو انجام میدادم نمیدونم از خستگی وقتی داشتم پوشه های خالی رو از public_path پاک میکردم حواسم نبود روی خوده پوشه هم alt گرفته بودم و همه چی پاک شد :( دنیا داش میچرخید دوره سرم همه استایل ها و js و و .. رف .. که با recently change داخل phpstorm فایل های پاک شده رو بازگردوندم شکر , اما حالا هر پروژه ای رو داخل phpstrom کار میکنم fontawesome دیییییگه لود نمیشه!؟؟؟؟ فقط جاش یه مربع کوچیکه؟ چرا واقعا؟؟؟ آدرس دهی مشکلی نداره چون قبلا کار میکرده!!! کسی میدونه چرا؟؟؟

میلاد ( 37480 تجربه )
7 روز پیش

سلام
خوشحالم که مشکل حادی برات پیش نیومده و تونستی درستش کنی.

اول از سایت https://fontawesome.com/start آخرین نسخه رو دریافت می کنی.

بعدش واسه استفاده از fontawesome باید دو کار کنی:

1 در پوشه فایل های css بیاد چنین فایلی رو قرار بدی: all-fontawesome.css
2 در پوشه fonts هم باید ی پوشه دیگه داشته باشی با این عنوان: webfonts-fontawesome که خود این پوشه هم محتویاتی از قبیل ِ fa-brands-400.eot و fa-brands-400.svg و ... داره (15 تا فایل هستش)

اینا رو بررسی کن، اگه موجود نیستند، پس قرارشون بده و ببین درست میشه یا نه.

سید زاهد حسینی ( 710 تجربه )
7 روز پیش

مرسی نه همونطور که گفتم قبله اینکه پاک بشن کاملا سالم بود و کار میکرد و پوشه ها مشکل خاصی نداشتن و ندارن،چون خیلی برام عجیب بود گفتم اینجا مطرح کنم و ببینم مشکل آیا از کش یا چیزی داخل phpstorm هست یا چیز دیگه،بهرحال متچکرم رفیق!

برای ارسال پاسخ باید وارد سایت شوید