مشکل در نصب پلاگین در فلاتر

- 1 هفته پیش
توسط EW آپدیت شد
الیاس بشکنی ( 8600 تجربه )
1 هفته پیش

سلام
من میخوام پلاگین های زیر رو نصب کنم ولی نمیدونم چرا ارور میدن

  http: ^0.12.0+2
  shared_preferences: ^0.5.3+1
  flutter_html_view: ^0.5.11

اینم اررو :

Running "flutter packages get" in alimelodi...                  
Because no versions of flutter_html_view match >0.5.11 <0.6.0 and flutter_html_view 0.5.11 depends on cached_network_image ^0.5.0+1, flutter_html_view ^0.5.11 requires cached_network_image ^0.5.0+1.
And because cached_network_image >=0.5.0+1 <0.6.0-alpha depends on flutter_cache_manager ^0.2.0+1, flutter_html_view ^0.5.11 requires flutter_cache_manager ^0.2.0+1.
Because flutter_cache_manager 0.2.0+1 depends on shared_preferences ^0.4.0 and no versions of flutter_cache_manager match >0.2.0+1 <0.3.0, flutter_cache_manager ^0.2.0+1 requires shared_preferences ^0.4.0.
Thus, flutter_html_view ^0.5.11 requires shared_preferences ^0.4.0.
So, because alimelodi depends on both flutter_html_view ^0.5.11 and shared_preferences ^0.5.3+1, version solving failed.

pub get failed (1)

مشکل از چی میتونه باشه؟ فلاتر رو هم آپدیت کردم
@hesammousavi

EW ( 3935 تجربه )
1 هفته پیش

همچین نسخه ای نیستش میتونید از ورژن

flutter_html_view: ^0.2.7

استفاده کنید

الیاس بشکنی ( 8600 تجربه )
1 هفته پیش
الیاس بشکنی ( 8600 تجربه )
1 هفته پیش

من تقریبا همیشه با نصب پلاگین مشکل دارم
همیشه به ورژن هاش گیر میده یا کلا با هم تداخل دارن انگاری
واقعا نمیدونم مشکل از چی میتونه باشه؟
چیز اضافه ای باید نصب کنم؟

EW ( 3935 تجربه )
1 هفته پیش

ایا شما دارید از cached_network_image استفاده میکنید؟ چون میگه که با نسخه اش تداخل داره میتونید اپدیتیش کنید

cached_network_image: ^0.8.0

اگر راه حل بالا جواب نداد همون نسخه رو بیارید پایین همونطور که بالاتر عرض کردم مشکل حل میشه

برای ارسال پاسخ باید وارد سایت شوید