آفلاین
user-avatar

مشکل در نصب پکیج sluggable

2 سال پیش
توسط مرتضی زارعی زکلیکی آپدیت شد
آفلاین
user-avatar
حجت ( 657 تجربه )
3 سال پیش

سلام دوستان من میخوام پکیج sluggable رو نصب کنم ولی خیلی زمان میبره آخرشم هم نصب نمیشه و این پیام رو میده

You are running Composer with SSL/TLS protection disabled.
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
The "http://packagist.org/p/provider-2014%242c5d5bc06c32f96c69dcd15a1f64d98d99c4a1149eed773627957d2c05b6d50c.json" file could not
be downloaded: failed to open stream: HTTP request failed!
http://packagist.org could not be fully loaded, package information was loaded from the local cache and may be out of date

راهی بهتر هم اگه میشه معرفی کنید برای ساخت slug

آفلاین
user-avatar
حسام موسوی ( 382169 تجربه )
3 سال پیش
تخصص : طراح و برنامه نویس

این مشکل مربوط به اینترنتون میشه .
لطفا این کد ها رو در داخل سه backtike باز و بسته قرار بدید

آفلاین
user-avatar
حجت ( 657 تجربه )
3 سال پیش
You are running Composer with SSL/TLS protection disabled.

./composer.json has been updated

Loading composer repositories with package information

Updating dependencies (including require-dev)

The "http://packagist.org/p/provider-۲۰۱۴%۲۴۲c۵d۵bc۰۶c۳۲f۹۶c۶۹dcd۱۵a۱f۶۴d۹۸d۹۹c۴a۱۱۴۹eed۷۷۳۶۲۷۹۵۷d۲c۰۵b۶d۵۰c.json" file could not

be downloaded: failed to open stream: HTTP request failed!

http://packagist.org could not be fully loaded, package information was loaded from the local cache and may be out of date
آفلاین
user-avatar
captan ( 1176 تجربه )
3 سال پیش

دو راه دارید :
یکی اینکه موقتا ssl-tls رو غیر فعالش کنید که خیلی ایمن نیست ولی مشکلتون رو حل میکنه

composer config -g -- disable-tls true

و راه بعدی اینکه در فایل php.ini خط زیر رو از حالت کامنت در بیارید

extension=php_openssl.dll
آفلاین
user-avatar
حجت ( 657 تجربه )
3 سال پیش

متاسفانه اصلا چیزی نمیتونم تو کامپوسر دانلود کنم

مثلا دستور نصب لاراول رو میزنم هیچ اتفاقی نمیوفته و پیامی نمیده و نصب نمیشه

آفلاین
user-avatar
Alex ( 75 تجربه )
3 سال پیش

سلام خدمت آقا مجید.
من وقتی از این پکیج استفاده می کنم و config:cache رو فراخوانی میکنم Error میده؟؟
میشه بگین چطوری میشه جلوی این خطا رو گرفت.

آفلاین
user-avatar
MOHAMMAD .D ( 25 تجربه )
3 سال پیش

"Your requirements could not be resolved to an installable set of packages.

Problem 1

  • illuminate/support v5.6.3 requires php ^7.1.3 -> your PHP version (7.0.10) does not satisfy that requirement.
  • illuminate/support v5.6.2 requires php ^7.1.3 -> your PHP version (7.0.10) does not satisfy that requirement.
  • illuminate/support v5.6.1 requires php ^7.1.3 -> your PHP version (7.0.10) does not satisfy that requirement.
  • illuminate/support v5.6.0 requires php ^7.1.3 -> your PHP version (7.0.10) does not satisfy that requirement.
  • cviebrock/eloquent-sluggable 4.5.0 requires illuminate/support ~5.6.0 -> satisfiable by illuminate/support[v5.6.0, v5.6.1, v5.6.2, v5.6.3].
  • Installation request for cviebrock/eloquent-sluggable 4.5 -> satisfiable by cviebrock/eloquent-sluggable[4.5.0].

Installation failed, reverting ./composer.json to its original content.
"

سلام و وقت بخیر خدمت دوستان
متاسفانه وقتی میخوام این پکیج رو نصب کنم با این خطا مواجه میشم
خیلی تو نت سرچ کردم ولی به نتیجه ای نرسیدم
اگر کسی میدونه لطفا راهنمایی کنه

آفلاین
user-avatar
مهدی ( 23202 تجربه )
3 سال پیش

سلام تو لاراول 5.6 استفاده میکنی php که داری رو آپدیت کن به 7.1.3 https://goo.gl/H1sE7M

یا از لینک زیر xampp رو آپدیت کن فرقی نداره در کل https://goo.gl/rL68HL

آفلاین
user-avatar
مرتضی زارعی زکلیکی ( 185 تجربه )
2 سال پیش
تخصص : توسعه دهنده سمت سرور

سلام به همه و از جمله MOHAMMAD .D
این سوالت برمیگرده به چند ماه پیش نمی دونم حلش کردی یا نه ؟
من خودم هم امروز با این خطا روبرو شدم و تونستم یجورایی حلش کنم اما قطعی نیستش؟ و (نظر شخصیمه) .
خطا می گه که نسخه ای که از لاراول استفاده می کنی با نسخه ای که می خوای از sluggable استفاده کنی همخوانی نداره ، مطابق صفحه ی زیر :
https://packalyst.com/packages/package/cviebrock/eloquent-sluggable
که میشه :
نسخه لاراول نسخه پکیج
5.6 => .4.5
5.5 =>
.4.3
5.4 => *.4.2
که برای اینکه به مشکلی برخورد نکنی در نصب ، باید نسخه لاراول با نسخه پکیج sluggable برابر باشه مانند :
مثلا می خوای در لاراول 5.5 این پکیج رو نصب کنی در composer تایپ می کنی :

composer require cviebrock/eloquent-sluggable:^4.3 

و خوب enter رو می زنی و نصب می کنی .
اما خوب قطعی نیست این روش ، چون در آینده قطعا مجبور میشی که نسخه لاراول رو آپدیت کنی و پکیجت رو هم اما برای حل کردن مشکل فکر کنم خوب باشه.
من خودمم این کار رو کردم ...

برای ارسال پاسخ باید وارد سایت شوید