description

مشکل در نصب phpstorm بر روی لینوکس

- 2 هفته پیش
توسط heather آپدیت شد
heather ( 593 تجربه )
2 هفته پیش

سلام دوستان محترم.
من می خواستم phpstorm رو نصب کنم...ولی قبل اون باید oracle-java8-installer نصب باشه ولی وقتی دستور نصب می زنم خطای زیر نمایش داده می شه.چند بار هم حذف و نصبش کردم ولی نتیجه همین بود.اگه اوراکل ما رو تحریم کرده باشه چی کار کنم؟

Oracle JDK 8 is NOT installed.
dpkg: error processing package oracle-java8-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)
بهترین پاسخ انتخاب شده توسط heather
مبین رجایی مقدم
2 هفته پیش

ببینید phpstorm و کلا jetbrain ها نیازمند لایبرری هایی برای اجرا هستند که یکی از اونا jdk هستش
این بسته که محصول شرکت اوراکل هم هست به صورت free (ازاد) روی اکثر توزیع های لینوکسی وجود داره . اگر خواستین ببینین که نصب هست یا نه دستور زیر رو وارد کنین :‌

if [[ $(java -version 2>&1) == _"OpenJDK"_ ]]; then echo ok; else echo 'not ok'; fi  

اگر ok بود که هیچ در غیر اینصورت اقدام به نصبش کنین . (برای این موضوع باور کنین با oracle jdk تفاوتی برای شما نداره )
برای نصب openjdk به walk through زیر برین (وبسایت رسمی)‌:‌

http://openjdk.java.net/install  

اگرم خواستین از oracle jdk استفاده کنین :
1) به سایت های دانلود ایرانی مراجعه کنین که با تقریب خوبی جدیدترین ورژن رو دانلود کنین.
2) از دستور های زیر به ترتیب استفاده کنین :

sudo rm -r /usr/lib/jvm/java-8-oracle/jdk1.8.0_66
sudo apt-get install -f  
sudo apt-get purge oracle-java8-installer  
sudo apt-get install oracle-java8-installer
vahid Mohammadi ( 2903 تجربه )
2 هفته پیش

@heather

سلام
از وب سایت زیر دانلود کنید و نصبش کنید بدون استفاده از ف...شکن

http://ghaffarian.net/downloads/Java/
مهدی طهرانی ( 6512 تجربه )
2 هفته پیش

@heather
سلام
دوست عزیز شما openjdk نصب کنی کفایت میکنه

مبین رجایی مقدم ( 317 تجربه )
2 هفته پیش

ببینید phpstorm و کلا jetbrain ها نیازمند لایبرری هایی برای اجرا هستند که یکی از اونا jdk هستش
این بسته که محصول شرکت اوراکل هم هست به صورت free (ازاد) روی اکثر توزیع های لینوکسی وجود داره . اگر خواستین ببینین که نصب هست یا نه دستور زیر رو وارد کنین :‌

if [[ $(java -version 2>&1) == _"OpenJDK"_ ]]; then echo ok; else echo 'not ok'; fi  

اگر ok بود که هیچ در غیر اینصورت اقدام به نصبش کنین . (برای این موضوع باور کنین با oracle jdk تفاوتی برای شما نداره )
برای نصب openjdk به walk through زیر برین (وبسایت رسمی)‌:‌

http://openjdk.java.net/install  

اگرم خواستین از oracle jdk استفاده کنین :
1) به سایت های دانلود ایرانی مراجعه کنین که با تقریب خوبی جدیدترین ورژن رو دانلود کنین.
2) از دستور های زیر به ترتیب استفاده کنین :

sudo rm -r /usr/lib/jvm/java-8-oracle/jdk1.8.0_66
sudo apt-get install -f  
sudo apt-get purge oracle-java8-installer  
sudo apt-get install oracle-java8-installer
heather ( 593 تجربه )
2 هفته پیش

@mrmm_11
@haghft
خیلی خیلی ممنون از شما .حل شد.

برای ارسال پاسخ باید وارد سایت شوید