آفلاین
user-avatar

خطا در نصب پکیج smsir

8 ماه پیش
توسط سیدعلی موسوی آپدیت شد
آفلاین
user-avatar
آرتا ( 8555 تجربه )
9 ماه پیش
تخصص : برنامه نویس وب و موبایل

سلام
برای نصب پکیج sms.ir  روی لاراول ۶ مشکل خوردم
خطا رو براتون ارسال کردم
قبلا تو ورژن قبلی درست کار میکرد
بعد آپدیت به ورژن ۶ لاراول این خطا رو در حین نصب میده

 % sudo composer require ipecompany/smsirlaravel                      
Password:
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Using version ^1.0 for ipecompany/smsirlaravel
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for laminas/laminas-diactoros (locked at 2.2.2, required as ^2.2) -> satisfiable by laminas/laminas-diactoros[2.2.2].
    - ipecompany/smsirlaravel v1.0.0 requires zendframework/zend-diactoros 1.*.* -> satisfiable by zendframework/zend-diactoros[1.8.x-dev].
    - ipecompany/smsirlaravel v1.0.1 requires zendframework/zend-diactoros 1.*.* -> satisfiable by zendframework/zend-diactoros[1.8.x-dev].
    - ipecompany/smsirlaravel v1.0.2 requires zendframework/zend-diactoros 1.*.* -> satisfiable by zendframework/zend-diactoros[1.8.x-dev].
    - ipecompany/smsirlaravel v1.0.3 requires zendframework/zend-diactoros 1.*.* -> satisfiable by zendframework/zend-diactoros[1.8.x-dev].
    - ipecompany/smsirlaravel v1.0.4 requires zendframework/zend-diactoros 1.*.* -> satisfiable by zendframework/zend-diactoros[1.8.x-dev].
    - ipecompany/smsirlaravel v1.0.5 requires zendframework/zend-diactoros 1.*.* -> satisfiable by zendframework/zend-diactoros[1.8.x-dev].
    - ipecompany/smsirlaravel v1.0.6 requires zendframework/zend-diactoros 1.*.* -> satisfiable by zendframework/zend-diactoros[1.8.x-dev].
    - ipecompany/smsirlaravel v1.0.7 requires zendframework/zend-diactoros 1.*.* -> satisfiable by zendframework/zend-diactoros[1.8.x-dev].
    - Conclusion: don't install zendframework/zend-diactoros 1.8.x-dev
    - Installation request for ipecompany/smsirlaravel ^1.0 -> satisfiable by ipecompany/smsirlaravel[v1.0.0, v1.0.1, v1.0.2, v1.0.3, v1.0.4, v1.0.5, v1.0.6, v1.0.7].

Installation failed, reverting ./composer.json to its original content.
آفلاین
user-avatar
پایان جهان ( 108665 تجربه )
9 ماه پیش
تخصص : جوجه برنامه نویس وردپرس و لاراول

درود...
دستور زیر:

composer require zendframework/zend-diactoros ^1.8
آفلاین
user-avatar
آرتا ( 8555 تجربه )
9 ماه پیش
تخصص : برنامه نویس وب و موبایل

@endworld
ممنونم
اینبار این خطا رو داد

sudo composer require zendframework/zend-diactoros ^1.8
Password:
Do not run Composer as root/super user! See https://getcomposer.org/root for details
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove laminas/laminas-diactoros 2.2.2
    - Conclusion: don't install laminas/laminas-diactoros 2.2.2
    - Conclusion: don't install laminas/laminas-diactoros 2.2.1p1
    - Conclusion: don't install laminas/laminas-diactoros 2.2.1
    - Conclusion: don't install laminas/laminas-diactoros 2.2.0p1
    - Conclusion: don't install laminas/laminas-diactoros 2.2.0
    - Conclusion: don't install laminas/laminas-diactoros 2.2.x-dev
    - don't install zendframework/zend-diactoros 1.8.0|don't install laminas/laminas-diactoros 2.2.2
    - don't install zendframework/zend-diactoros 1.8.1|don't install laminas/laminas-diactoros 2.2.2
    - don't install zendframework/zend-diactoros 1.8.2|don't install laminas/laminas-diactoros 2.2.2
    - don't install zendframework/zend-diactoros 1.8.3|don't install laminas/laminas-diactoros 2.2.2
    - don't install zendframework/zend-diactoros 1.8.4|don't install laminas/laminas-diactoros 2.2.2
    - don't install zendframework/zend-diactoros 1.8.5|don't install laminas/laminas-diactoros 2.2.2
    - don't install zendframework/zend-diactoros 1.8.6|don't install laminas/laminas-diactoros 2.2.2
    - don't install zendframework/zend-diactoros 1.8.7|don't install laminas/laminas-diactoros 2.2.2
    - don't install zendframework/zend-diactoros 1.8.x-dev|don't install laminas/laminas-diactoros 2.2.2
    - Installation request for laminas/laminas-diactoros ^2.2 -> satisfiable by laminas/laminas-diactoros[2.2.0, 2.2.0p1, 2.2.1, 2.2.1p1, 2.2.2, 2.2.x-dev].
    - Installation request for zendframework/zend-diactoros ^1.8 -> satisfiable by zendframework/zend-diactoros[1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.8.7, 1.8.x-dev].

Installation failed, reverting ./composer.json to its original content.
آفلاین
user-avatar
آرتا ( 8555 تجربه )
8 ماه پیش
تخصص : برنامه نویس وب و موبایل

کسی پکیج  sms.ir روی در لاراول ۶ نصب کرده راهنمایی بدید لطفا؟؟

آفلاین
user-avatar
سیدعلی موسوی ( 107738 تجربه )
8 ماه پیش
تخصص : سی شارپ و پی اچ پی

من نصب نکرم ولی تویی سایتش api داده میتونی با guzzleHttp یا SoapClient کار کنی دیگه!! پکیچ برای چی ؟!

آفلاین
user-avatar
سیدعلی موسوی ( 107738 تجربه )
8 ماه پیش
تخصص : سی شارپ و پی اچ پی

برای دوتا خطای بالا هم اینجور که مشخصه شما composer مشکل داره برای اجرا

Password:
Do not run Composer as root/super user! See https://getcomposer.org/root for details
./composer.json has been updated
برای ارسال پاسخ باید وارد سایت شوید